Archive

Archive for the ‘Notes’ Category

Alter embed URL letter case to fix your broken MS-Office-file embeds in WordPress

  1. Problem: I just notice that a lot of my WordPress OneDrive embeds are broken (not sure since when).
  2. Root cause:
    1. Upon comparing the embed URLS in WordPress posts with what embed URLS sharing with OneDrive results in, it appears that the letter case in the embed URLs has been changed to all uppercase, pointing to resources that do not exist (doh!).
    2. Not sure who is to blame for altering the case:
      1. WordPress,
      2. OneDrive (note there is also the transition from “skydrive” to “onedrive”),
      3. Windows Live Writer? The latter hardly, since I did not touch these posts.
  3. Solution:
    1. Given that, while “cid=” seems all uppercase, “resid=” all lowercase, but “authkey=” is mixed case , there is not easy case change operation you could do locally to restore the original try.
    2. So you have to find the original files you embedded (not trivial from the URL which does not contain even a hint of the file name or extension) and re-embed it through sharing with OneDrive.

Stop ":Zone.Identifier:$DATA" files from being created…

  1. … by running gpedit.msc as admin and setting "user configuration / administrative templates / windows components/ attachment manager / "Do not preserve zone information in file attachments" to "Enabled         No. "
    1. I observed these files in the drive my virtualbox win 8.shares with the linux host.
    2. The answer is out there , of course,  just not with all the search terms. A more thorough security discussion is also available.
    3. Just seems not applicable to a share what virtualbox makes appear as a network folder to Windows while it really is not, which causes also other misleading security warnings also : image

How to fix MS-Word not creating PDF Bookmarks for your Headings

  1. Problem: No navigation bar in Acrobat Reader when viewing your PDF created from MS-Word.
  2. Solution: Check this setting first in the Save as PDF Options: image
  3. But: Word 2013’s  “Save as PDF” with “Create Bookmarks”  may remains greyed out since it won’t even see your own heading styles, even if you based these styles on the built-in heading styles (which are known to contain  “hidden magic” not easily replicated) , including their outline level, if
    1. Heading appears in Content control.
    2. Heading appears in Table.
  4. Workaround:
    1. Move headings out of Content Controls (you can still “lock”the text with Grouping, which will be enabled on the Developer Tab once you select at least a conten control and text (meant for form field labels).
    2. Move headings outside of tables.

How to fix primary screen on Linux laptop not coming out of sleep

  1. Problem: My Debian (Jessie) Linux laptop has issues with juggling a secondary screen and sleeping at the same time. More specifically, it seems:
    1. It seems if you come out of sleep with a secondary screen connected, even if you put the laptop to sleep with “it” (o.k., not the same “it”, just spec-wise the equivalent FULL HD LCD screen on VGA – being able to easily move the laptop to work in multiple places is kind of the point of having one in the first place), the primary laptop screen seems to remain asleep completely. FN keys to switch primary and secondary screen on laptop have no effect.
    2. If you disconnect the secondary screen, Linux does fall back onto the primary screen, however, “forgets” to turn the backlight on. FN keys to up brightness have no effect
    3.   have not found a reliable way avoiding the issue  – maybe always disconnecting secondary screen before putting laptop to sleep? If you don’t want to have to do this, or forget, try to use this:
  2. Workaround:
    1. While I could get to the tty shell on secondary screen using CTRL+ALT+F1, but using xrandr --auto gave can't open display.
    2. However, try installing this utility which I found recommended in a different context:
      1. aptitude search xbacklight
      2. xbacklight               - simple utility to set the backlight level
      3. aptitude install xbacklight
      4. Switch to a non-elevated user (or else you’ll get: No protocol specified" , "Primary laptop", "Can't open display :0", Why can't I run GUI apps from 'root': "No protocol specified"? : " In Debian $XAUTHORITY is usually not set explicitly.", "xauth list xauth:  file /root/.Xauthority does not exist" ).
      5. Then issue: xbacklight -set 50 OR issue xbacklight -inc 50.
      6. Viola: “Fiat lux”…
      7. Sleep takes out your primary screen and you are not good at blind starting, finding and typing into your Konsole? Right-click on the desktop of your secondary scree, “Run command”, and issue the same command line.
      8. Thank you, xbacklight.

Bad audio quality in Moodle Kaltura recordings on iMacs under ambient sound conditions. A running log (closed)

  1. Symptom: See title.
  2. Cause: While speakers of the 3.5 mm headset take over from the iMac speakers, when plugged in, the 3.5 mm headset micro does not disable the webcam micro. The webcam micro remains the recording source for Moodle Kaltura (mac os x.6, safari 6, flash 10).
  3. Possible solutions:
      1. 1st choice: is there a way for the admin to override this permanently?
      2. 2nd choice: is there a way for the end user to override this on a case-by-case basis?
      3. "The Califone 3066AV is compatible with both Windows and Mac audio outputs (but is not compatible with iMacs)." ("The Wow starts now!").. Do we have to tie up our boom and lavalier microphones for this?
      4. Try the flash settings by right clicking in the video window, selecting the microphone icon, then choosing the external (= non-webcam) microphone for input.
      5. kaltura flash microphone settings0kaltura flash microphone settings
      6. Fail. The real culprit is the iMacs line-in audio-in for which you need a preamp to get it to work with analog microphones. Preamps seem to start at $40, but for that I can get a PC webcam (Microphone included). 

POS-Tagsets. A list.

Windowing system infinite loop on windows 8.1

  1. Rather annoying, no getting out of this loop, endless window foreground switching, but also unclear about the screen resolution, it seems. Ha
  2. Oh, wait, I changed the dpi scaling, but chose to not log off, has that got something to do with this? Well, I have seen this loop behavior before, and I also frequent get terrible slowdowns which I have not been able to do root cause analysis for (also video-related? or network? )
  3. Either way, likely related frequent explorer crashes which downgrade from aero. Sometimes I lose Aero’s advanced task scheduler completely, here I have a screenshot of it just coming back: CAM07615
  4. Have not been able to find other similar problem / but reports – something wrong with my setup then? (never mind that my camera has its own infinite loop auto focus bug.